插件之间jquery版本冲突

提问 未结
3 1238
吴恩文
吴恩文 2016-6-21
悬赏:5飞吻
我在某个母版页中加载了1.3版的jquery,在再具体页面中加载了1.9.1的jquery结果layer(最新版)和另一个插件不能同时使用了,我想问问这种情况该如何处理啊,顺便问下早期版本的layer在哪里下载啊
回帖
  • indiboy
    indiboy (该号已被封)
    2016-6-21
    理论上是可以兼容的,看看报什么错,稍微调整下即可。
    0 回复
  • 吴恩文
    2016-6-22
    @indiboyVIP1 我用1.3.2的时候报对象不支持该方法,我格式化代码后找到是第242行a.vessel(j, 这一行
    0 回复
  • 如果你非要这么使用的画,建议使用seajs区分一下,或者

    <script >try{var jq132=jQuery.noConflict();jQuery = $ =null;}catch(e){console.log(a)}</script >
    <script src="/jquery.minjs"></script>//load jqv1.9.1
    0 回复
本帖已设置禁止回复