调查:layer有必要不再对ie6/7进行支持吗?

精帖 未结贴
24 2957
layer一直以来都是兼容包括ie6/7在内的全部浏览器,但鉴于目前ie6、7的市场份额日渐下降,layer中对ie6/7一些特别兼容的代码有必要剔除吗?

考虑到一些用户仍需对ie6做兼容,我们原计划是在 layer 独立组件的 3.0 版本完全放弃ie6/7(请注意,layer是区别于layui框架体系的一个独立弹层组件),但现在正在考虑在 layer的下个版本(2.5)即剔除,最低支持ie8,预计将因此减少 3 - 5kb的代码,你们觉得意下如何呢?
  • 單克拉的眼淚 單克拉的眼淚 VIP0
    2016-09-09 21:53:17
    有必要保留,最好分两个版本,版本号单数不支持ie双数支持ie,一次发两个版本即可。要知道有很多用户都是本着ie6,7来的。只想对于那些说文件减少文件大小的人来说:如果3-5K可以解决IE6,7支持问题,那就必须要保留,bootstrap太庞大,对于它来说增加3-5K可能有问题,但对于layer来说,3-5K不是问题,哪怕100K,我都可以容忍,现阶段放弃支持不是明智的选择,过两年获取可以。。
    1 回复
  • 我是隔壁云老王 我是隔壁云老王 VIP1
    2016-09-10 14:56:33
    还是建议从3.0 之后再放弃。
    放弃并不是因为代码体积,而是对IE的立场和态度。
    我jQuery 都用了 ,还会在乎 那几KB的大小吗?
    1 回复
  • 火端网络 火端网络
    2016-09-09 20:27:49
    老版本的也已经比较完善了,新版本的可以不考虑了。
    如果只是3~5kb,也可以考虑保留
    0 回复
  • 阳阳VIP 阳阳VIP VIP1
    2016-09-09 20:40:36
    随大流,毕竟我们搞开发的都不希望客户用ie8以下的浏览器访问我们所建设的站点,建议剔除点,最低支持ie8以上。毕竟现在ie6/7已经逐渐退出我们的桌面了,做开发的更讨厌6/7浏览器
    0 回复
  • 第一把菜刀 第一把菜刀
    2016-09-09 20:45:28
    不建议兼容,也没必要兼容
    0 回复
  • Website Website VIP0
    2016-09-09 20:45:30
    删除 ie 6、7 是没问题的!
    特别是ie6这个反人类的浏览器!
    话说,用ie6的 貌似都自动升级成 360 浏览器 或者 QQ浏览器了吧?
    [偷笑]
    0 回复
  • Soul Soul
    2016-09-09 21:06:17
    提了,ie怎么低的基本很少用了,所以别浪费资源[馋嘴]
    0 回复
  • 小胖鑫 小胖鑫
    2016-09-09 21:32:39
    去掉吧[嘻嘻]
    0 回复
  • 凶狠的小白免 凶狠的小白免
    2016-09-09 22:22:36
    你敢支持这两个垃圾货,我砍死你
    0 回复
  • 红尘客栈 红尘客栈
    2016-09-09 22:55:54
    我觉得现在取消这2个还是有点早了!因为现在微软堆win10的统计数都不高说明试用的人还是会存在!建议可以保留一个版本是能支持的!后面升级的可以直接放弃
    0 回复
  • 伶俜夜 伶俜夜
    2016-09-09 23:06:18
    不用 直接最低ie8就好了
    0 回复
  • 烧炖 烧炖
    2016-09-10 01:49:01
    不用支持了,没必要为他们续命
    0 回复
  • 虎嗅蔷薇 虎嗅蔷薇
    2016-09-10 18:35:43
    删删删,别说ie6/7了,IE8看了都烦~
    0 回复
  • 放肆 放肆
    2016-09-11 12:37:40
    用layer唯一的理由不就是还有IE兼容么,不然国外弹窗控件写的好的多了去了干嘛不用,代码少量的代码量不是问题。正常业务少放个图片几十KB就出来了
    0 回复
  • kunhour kunhour VIP2
    2016-09-11 13:00:16
    支持不支持IE67,毕竟太古老。
    0 回复
  • Everlasting Everlasting VIP0
    2016-09-11 15:16:09
    不用支持了,快放弃了,放弃了才能走的更远
    0 回复
  • yepcheng yepcheng VIP2
    2016-09-14 18:37:45
    不要去支持
    0 回复
  • humo humo VIP0
    2016-09-14 22:12:18
    没必要支持 已考虑兼容问题就接踵而至......
    0 回复
  • Seamless Seamless SVIP
    2016-09-15 19:15:04
    如果代碼上獨立出來沒問題的話,建議作為附加文件單獨提供。後續只要沒問題就不做更新。
    0 回复
  • 蓝猴子 蓝猴子
    2016-09-16 13:47:25
    没有必要,要有壮士断腕的决心!
    0 回复
  • 科联工作室 科联工作室
    2016-10-23 18:23:04
    一百人中至少还有一两个人是IE6,如果代码只是3~5kb,也可以考虑保留
    0 回复
  • 毅者远翔 毅者远翔
    2016-10-30 22:12:26
    完全没必要了!如果确实需要IE6、7支持,发布最后一个版本就停止更新,让那些用户就用这最后一个版本吧
    0 回复
  • 疑视 疑视
    2016-12-30 18:30:49
    至少要支持IE8
    0 回复
  • 疑视 疑视
    2016-12-30 18:31:30
    在我们国家,支持Ie8是必须的呀
    0 回复
最近热帖
layui所在服务器近期连续遭受DDoS攻击 3322
vip-admin Html v1.7.0 更新了 - 基于layui的后台模板 970
用layui做管理后台的请进 671
有学生愿意接活干吗?做网站!价格不是很高但是经常有活干 449
select 下拉复选框 244
小魔方看到请进来,你的解决方法有bug 209
layui的编辑器是怎么配置出来的啊,难道不是layedit? 201
发现最新版layui的一个小BUG 177
layui和vue的相性貌似不是很好,求解 174
初次使用layer 发生了,这种情况,究竟是为何? 169
近期热议
layui所在服务器近期连续遭受DDoS攻击 35
弹出层不能置顶!! 12
初次使用layer 发生了,这种情况,究竟是为何? 12
急!修改回显问题~~~~ 10
layui的编辑器是怎么配置出来的啊,难道不是layedit? 10
各位大神们早上好,小弟有一个问题。 10
求救关于layer.msg的问题 9
求助。。。循环绑定传值问题 9
小魔方看到请进来,你的解决方法有bug 8
【求助】layer弹层,type1,firefox,ie8—11,当元素display为none,无 7