一直报xmSelect模块不可用的错

提问 未结 12 331
404pojo
404pojo 2020-1-20
悬赏:20飞吻
版本:扩展组件 浏览器:chrome
其他插件可以用,xmSelect一直报这个错:

下面是我的加载模块的代码:

回帖
  • xm-select文件名改为xmSelect
    0 回复
  • 404pojo
    2020-1-20
    @荒街 是将路径和文件都改吗,我改完报的是同样的错

    0 回复
  • 难得920
    2020-1-20
    layui.config({
    base: './static/plugins/layui'
    }).extend({
    xmSelect: 'xmSelect/xm-Select'
    }).use(['xmSelect'], function(){
    0 回复
  • 难得920
    2020-1-20
    @难得920 layui.config({
    base: './static/plugins/layui/'
    }).extend({
    xmSelect: 'xmSelect/xm-Select'
    }).use(['xmSelect'], function(){
    0 回复
  • 404pojo
    2020-1-20
    @难得920 把xm-select改成大写xm-Select了,还是报错[可怜]
    0 回复
  • 404pojo
    2020-1-20
    完全按照官网上也是一样的问题,报xmSelect is not a valid module的错
    0 回复
  • 难得920
    2020-1-20
    @404pojo 文件名一致也报错吗
    0 回复
  • 缘遇静
    2020-1-20
    @404pojo 直接引入js不就行了<script src="/js/xm-select.js"></script>,开始你的表演
    0 回复
  • 404pojo
    2020-1-20
    @难得920
    0 回复
  • 404pojo
    2020-1-20
    @缘遇静 官网上也是说直接引入js文件,但是这里面的xmSelect变量是怎么来的啊
    第一步: 下载
    第二步: 引入 xm-select.js
    第三步: 写一个`<div id="demo1"></div>`
    第四步: 渲染
    var demo1 = xmSelect.render({
    el: '#demo1',
    language: 'zn',
    data: [
    {name: '张三', value: 1},
    {name: '李四', value: 2},
    {name: '王五', value: 3},
    ]
    })
    0 回复